Guideline Guru - Issues with our primary database – Incident details

Issues with our primary database

Resolved
Major outage
Started 7 months agoLasted 44 minutes

Affected

App

Major outage from 10:00 PM to 10:43 PM

Updates
  • Postmortem
    Postmortem

    On September 15th, Guideline Guru experienced a service outage from 5:59 PM to 6:40 PM ET, during which the app was unavailable.

    The outage was caused by a new document processing feature that placed unexpected CPU strain on our database. This led the database to stop responding to management commands and temporarily took the application offline.

    We restored service by moving to a fresh database instance, and we can confirm that no customer data was lost. Since then, we’ve begun upgrading our database infrastructure and improving monitoring so that similar issues can be prevented or resolved much more quickly.

    We deeply apologize for this disruption. Thank you for your patience and continued trust as we make Guideline Guru more reliable every day.

  • Resolved
    Resolved
    This incident has been resolved.
  • Monitoring
    Monitoring
    We implemented a fix and are currently monitoring the result.
  • Identified
    Identified
    We are continuing to work on a fix for this incident.